#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:foo|bar)\h*)+$"
Local $sString = "foo" & @CRLF & _
"bar" & @CRLF & _
"barfoo" & @CRLF & _
"foobarbarfoofoobar" & @CRLF & _
"foo bar" & @CRLF & _
"foo foo bar" & @CRLF & _
" " & @CRLF & _
"foo bar ipsum dolor sit amet, consectetur adipiscing elit" & @CRLF & _
"ipsum dolor sit amet, consectetur adipiscing elit foo" & @CRLF & _
"ipsum dolor sit amet, bar consectetur adipiscing elit foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")