re = /^((?:foo|bar)\h*)+$/m
str = 'foo
bar
barfoo
foobarbarfoofoobar
foo bar
foo foo bar
foo bar ipsum dolor sit amet, consectetur adipiscing elit
ipsum dolor sit amet, consectetur adipiscing elit foo
ipsum dolor sit amet, bar consectetur adipiscing elit foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end