import re
regex = re.compile(r"^((?:foo|bar)\h*)+$", flags=re.MULTILINE)
test_str = ("foo\n"
"bar\n"
"barfoo\n"
"foobarbarfoofoobar\n"
"foo bar\n"
"foo foo bar\n"
" \n"
"foo bar ipsum dolor sit amet, consectetur adipiscing elit\n"
"ipsum dolor sit amet, consectetur adipiscing elit foo\n"
"ipsum dolor sit amet, bar consectetur adipiscing elit foo")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")