$re = '/^((?:foo|bar)\h*)+$/m';
$str = 'foo
bar
barfoo
foobarbarfoofoobar
foo bar
foo foo bar
foo bar ipsum dolor sit amet, consectetur adipiscing elit
ipsum dolor sit amet, consectetur adipiscing elit foo
ipsum dolor sit amet, bar consectetur adipiscing elit foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);