import Foundation
let pattern = #"^((?:foo|bar)\h*)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foo
bar
barfoo
foobarbarfoofoobar
foo bar
foo foo bar
foo bar ipsum dolor sit amet, consectetur adipiscing elit
ipsum dolor sit amet, consectetur adipiscing elit foo
ipsum dolor sit amet, bar consectetur adipiscing elit foo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)