use strict;
my $str = 'foo
bar
barfoo
foobarbarfoofoobar
foo bar
foo foo bar
foo bar ipsum dolor sit amet, consectetur adipiscing elit
ipsum dolor sit amet, consectetur adipiscing elit foo
ipsum dolor sit amet, bar consectetur adipiscing elit foo';
my $regex = qr/^((?:foo|bar)\h*)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}