# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)(?:<p|\G(?!\A))(?:(?!<\\/p>).)*?\K[\n\r]+//gm;t' <<< "<p dir=\"ltr\">Test<br>
A
aa</p>
abcd
<p dir=\"ltr\">Bbb</p>"