use strict;
my $str = '<p dir="ltr">Test<br>
A
aa</p>
abcd
<p dir="ltr">Bbb</p>';
my $regex = qr/(?s)(?:<p|\G(?!\A))(?:(?!<\/p>).)*?\K[\n\r]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";