re = /(?s)(?:<p|\G(?!\A))(?:(?!<\/p>).)*?\K[\n\r]+/m
str = '<p dir="ltr">Test<br>
A
aa</p>
abcd
<p dir="ltr">Bbb</p>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result