$re = '/(?s)(?:<p|\G(?!\A))(?:(?!<\/p>).)*?\K[\n\r]+/m';
$str = '<p dir="ltr">Test<br>
A
aa</p>
abcd
<p dir="ltr">Bbb</p>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;