import re
regex = re.compile(r"(?s)(?:<p|\G(?!\A))(?:(?!<\/p>).)*?\K[\n\r]+", flags=re.MULTILINE)
test_str = ("<p dir=\"ltr\">Test<br>\n"
"A\n"
"aa</p>\n"
"abcd\n"
"<p dir=\"ltr\">Bbb</p>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)