#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)(?:<p|\G(?!\A))(?:(?!<\/p>).)*?\K[\n\r]+"
Local $sString = "<p dir="ltr">Test<br>" & @CRLF & _
"A" & @CRLF & _
"aa</p>" & @CRLF & _
"abcd" & @CRLF & _
"<p dir="ltr">Bbb</p>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)