package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`PRICE:\s+\$([\.\d]+)`)
var str = ` <span class='product'>Cheese</span>
<ul class='product-details' >
<li class='price' id='Cheese-price'> PRICE: $32.23 </li>
<li class='weight' id='Cheese-weight'> WEIGHT: 100 lbs </li>
</ul>
<span class='product'>Apple</span>
<ul class='product-details' >
<li class='price' id='Apple-price'> PRICE: $2.23 </li>
<li class='weight' id='Apple-weight'> WEIGHT: 1 lbs </li>
</ul>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}