# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"PRICE:\s+\$([\.\d]+)"
test_str = (" <span class='product'>Cheese</span>\n"
" <ul class='product-details' >\n"
" <li class='price' id='Cheese-price'> PRICE: $32.23 </li>\n"
" <li class='weight' id='Cheese-weight'> WEIGHT: 100 lbs </li> \n"
" </ul>\n"
" <span class='product'>Apple</span>\n"
" <ul class='product-details' >\n"
" <li class='price' id='Apple-price'> PRICE: $2.23 </li>\n"
" <li class='weight' id='Apple-weight'> WEIGHT: 1 lbs </li> \n"
" </ul>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.