import Foundation
let pattern = #"PRICE:\s+\$([\.\d]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<span class='product'>Cheese</span>
<ul class='product-details' >
<li class='price' id='Cheese-price'> PRICE: $32.23 </li>
<li class='weight' id='Cheese-weight'> WEIGHT: 100 lbs </li>
</ul>
<span class='product'>Apple</span>
<ul class='product-details' >
<li class='price' id='Apple-price'> PRICE: $2.23 </li>
<li class='weight' id='Apple-weight'> WEIGHT: 1 lbs </li>
</ul>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)