use strict;
my $str = ' <span class=\'product\'>Cheese</span>
<ul class=\'product-details\' >
<li class=\'price\' id=\'Cheese-price\'> PRICE: $32.23 </li>
<li class=\'weight\' id=\'Cheese-weight\'> WEIGHT: 100 lbs </li>
</ul>
<span class=\'product\'>Apple</span>
<ul class=\'product-details\' >
<li class=\'price\' id=\'Apple-price\'> PRICE: $2.23 </li>
<li class=\'weight\' id=\'Apple-weight\'> WEIGHT: 1 lbs </li>
</ul>';
my $regex = qr/PRICE:\s+\$([\.\d]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}