$re = '/PRICE:\s+\$([\.\d]+)/';
$str = ' <span class=\'product\'>Cheese</span>
<ul class=\'product-details\' >
<li class=\'price\' id=\'Cheese-price\'> PRICE: $32.23 </li>
<li class=\'weight\' id=\'Cheese-weight\'> WEIGHT: 100 lbs </li>
</ul>
<span class=\'product\'>Apple</span>
<ul class=\'product-details\' >
<li class=\'price\' id=\'Apple-price\'> PRICE: $2.23 </li>
<li class=\'weight\' id=\'Apple-weight\'> WEIGHT: 1 lbs </li>
</ul>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);