// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"PRICE:\s+\$([\.\d]+)").unwrap();
let string = " <span class='product'>Cheese</span>
<ul class='product-details' >
<li class='price' id='Cheese-price'> PRICE: $32.23 </li>
<li class='weight' id='Cheese-weight'> WEIGHT: 100 lbs </li>
</ul>
<span class='product'>Apple</span>
<ul class='product-details' >
<li class='price' id='Apple-price'> PRICE: $2.23 </li>
<li class='weight' id='Apple-weight'> WEIGHT: 1 lbs </li>
</ul>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}