using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"start\s(?:(test\d+)(?:\s?(?:[,&]|and)\s?)?)+";
string input = @"bla bla start test1, test2, test3 and test4 & test12 but not test5, test6 or test33, and start test100.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}