const regex = /start\s(?:(test\d+)(?:\s?(?:[,&]|and)\s?)?)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('start\\s(?:(test\\d+)(?:\\s?(?:[,&]|and)\\s?)?)+', 'g')
const str = `bla bla start test1, test2, test3 and test4 & test12 but not test5, test6 or test33, and start test100.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}