use strict;
my $str = 'bla bla start test1, test2, test3 and test4 & test12 but not test5, test6 or test33, and start test100.';
my $regex = qr/start\s(?:(test\d+)(?:\s?(?:[,&]|and)\s?)?)+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}