import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "start\\s(?:(test\\d+)(?:\\s?(?:[,&]|and)\\s?)?)+";
final String string = "bla bla start test1, test2, test3 and test4 & test12 but not test5, test6 or test33, and start test100.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}