re = /start\s(?:(test\d+)(?:\s?(?:[,&]|and)\s?)?)+/
str = 'bla bla start test1, test2, test3 and test4 & test12 but not test5, test6 or test33, and start test100.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end