import Foundation
let pattern = #"start\s(?:(test\d+)(?:\s?(?:[,&]|and)\s?)?)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"bla bla start test1, test2, test3 and test4 & test12 but not test5, test6 or test33, and start test100."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)