package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`start\s(?:(test\d+)(?:\s?(?:[,&]|and)\s?)?)+`)
var str = `bla bla start test1, test2, test3 and test4 & test12 but not test5, test6 or test33, and start test100.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}