#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https?:\/\/(www.|de.)?linkedin.com\/(mwlite\/|m\/)?in\/([a-zA-Z0-9À-ž_.-]+)\/?)"
Local $sString = "https://de.linkedin.com/in/andré-test-9dfdr47a16a" & @CRLF & _
"https://www.linkedin.com/in/lenatest/" & @CRLF & _
"https://de.linkedin.com/in/test-jäcke-dff0746" & @CRLF & _
"https://de.linkedin.com/in/irenetest" & @CRLF & _
"https://www.linkedin.com/in/markus-test-7dfdfc38/?originalSubdomain=de" & @CRLF & _
"https://www.linkedin.com/in/test-görs-2fdf562a/" & @CRLF & _
"https://www.linkedin.com/in/test-müller-82dfdfd0143/" & @CRLF & _
"https://www.linkedin.com/in/marie-test-grübler-dfdfdsf0/" & @CRLF & _
"https://www.linkedin.com/in/özgür-test-dfdfdf080/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")