using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/(www.|de.)?linkedin.com\/(mwlite\/|m\/)?in\/([a-zA-Z0-9À-ž_.-]+)\/?)";
string input = @"https://de.linkedin.com/in/andré-test-9dfdr47a16a
https://www.linkedin.com/in/lenatest/
https://de.linkedin.com/in/test-jäcke-dff0746
https://de.linkedin.com/in/irenetest
https://www.linkedin.com/in/markus-test-7dfdfc38/?originalSubdomain=de
https://www.linkedin.com/in/test-görs-2fdf562a/
https://www.linkedin.com/in/test-müller-82dfdfd0143/
https://www.linkedin.com/in/marie-test-grübler-dfdfdsf0/
https://www.linkedin.com/in/özgür-test-dfdfdf080/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}