import Foundation
let pattern = #"(https?:\/\/(www.|de.)?linkedin.com\/(mwlite\/|m\/)?in\/([a-zA-Z0-9À-ž_.-]+)\/?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://de.linkedin.com/in/andré-test-9dfdr47a16a
https://www.linkedin.com/in/lenatest/
https://de.linkedin.com/in/test-jäcke-dff0746
https://de.linkedin.com/in/irenetest
https://www.linkedin.com/in/markus-test-7dfdfc38/?originalSubdomain=de
https://www.linkedin.com/in/test-görs-2fdf562a/
https://www.linkedin.com/in/test-müller-82dfdfd0143/
https://www.linkedin.com/in/marie-test-grübler-dfdfdsf0/
https://www.linkedin.com/in/özgür-test-dfdfdf080/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)