use strict;
my $str = 'https://de.linkedin.com/in/andré-test-9dfdr47a16a
https://www.linkedin.com/in/lenatest/
https://de.linkedin.com/in/test-jäcke-dff0746
https://de.linkedin.com/in/irenetest
https://www.linkedin.com/in/markus-test-7dfdfc38/?originalSubdomain=de
https://www.linkedin.com/in/test-görs-2fdf562a/
https://www.linkedin.com/in/test-müller-82dfdfd0143/
https://www.linkedin.com/in/marie-test-grübler-dfdfdsf0/
https://www.linkedin.com/in/özgür-test-dfdfdf080/';
my $regex = qr/(https?:\/\/(www.|de.)?linkedin.com\/(mwlite\/|m\/)?in\/([a-zA-Z0-9À-ž_.-]+)\/?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}