const regex = /(https?:\/\/(www.|de.)?linkedin.com\/(mwlite\/|m\/)?in\/([a-zA-Z0-9À-ž_.-]+)\/?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/(www.|de.)?linkedin.com\\\/(mwlite\\\/|m\\\/)?in\\\/([a-zA-Z0-9À-ž_.-]+)\\\/?)', 'gm')
const str = `https://de.linkedin.com/in/andré-test-9dfdr47a16a
https://www.linkedin.com/in/lenatest/
https://de.linkedin.com/in/test-jäcke-dff0746
https://de.linkedin.com/in/irenetest
https://www.linkedin.com/in/markus-test-7dfdfc38/?originalSubdomain=de
https://www.linkedin.com/in/test-görs-2fdf562a/
https://www.linkedin.com/in/test-müller-82dfdfd0143/
https://www.linkedin.com/in/marie-test-grübler-dfdfdsf0/
https://www.linkedin.com/in/özgür-test-dfdfdf080/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}