package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/(www.|de.)?linkedin.com\/(mwlite\/|m\/)?in\/([a-zA-Z0-9À-ž_.-]+)\/?)`)
var str = `https://de.linkedin.com/in/andré-test-9dfdr47a16a
https://www.linkedin.com/in/lenatest/
https://de.linkedin.com/in/test-jäcke-dff0746
https://de.linkedin.com/in/irenetest
https://www.linkedin.com/in/markus-test-7dfdfc38/?originalSubdomain=de
https://www.linkedin.com/in/test-görs-2fdf562a/
https://www.linkedin.com/in/test-müller-82dfdfd0143/
https://www.linkedin.com/in/marie-test-grübler-dfdfdsf0/
https://www.linkedin.com/in/özgür-test-dfdfdf080/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}