using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\[]*(\[.*?\])[^\[]*";
string substitution = @"\1";
string input = @"[D-1.1.1-A] - bla bla text here[D-1.1.1-B] - some more bla bla text here[D-1.1.1-C] - even more bla bla
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}