import Foundation
let pattern = #"[^\[]*(\[.*?\])[^\[]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[D-1.1.1-A] - bla bla text here[D-1.1.1-B] - some more bla bla text here[D-1.1.1-C] - even more bla bla
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)