package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\[]*(\[.*?\])[^\[]*`)
var str = `[D-1.1.1-A] - bla bla text here[D-1.1.1-B] - some more bla bla text here[D-1.1.1-C] - even more bla bla
`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}