const regex = /[^\[]*(\[.*?\])[^\[]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\[]*(\\[.*?\\])[^\\[]*', 'g')
const str = `[D-1.1.1-A] - bla bla text here[D-1.1.1-B] - some more bla bla text here[D-1.1.1-C] - even more bla bla
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);