re = /[^\[]*(\[.*?\])[^\[]*/
str = '[D-1.1.1-A] - bla bla text here[D-1.1.1-B] - some more bla bla text here[D-1.1.1-C] - even more bla bla
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result