import re
regex = re.compile(r"[^\[]*(\[.*?\])[^\[]*")
test_str = ("[D-1.1.1-A] - bla bla text here[D-1.1.1-B] - some more bla bla text here[D-1.1.1-C] - even more bla bla\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)