#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)[\x{627}\x{625}\x{623}\x{622}]\x{062D}\x{0645}\x{062F}"
Local $sString = "Ø£ØÙ…د" & @CRLF & _
"اØÙ…د" & @CRLF & _
"Ø¥ØÙ…د" & @CRLF & _
"Ø¢ØÙ…د"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")