re = /[\x{627}\x{625}\x{623}\x{622}]\x{062D}\x{0645}\x{062F}/
str = 'Ø£ØÙ…د
اØÙ…د
Ø¥ØÙ…د
Ø¢ØÙ…د'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end