import re
regex = re.compile(r"[\x{627}\x{625}\x{623}\x{622}]\x{062D}\x{0645}\x{062F}", flags=re.UNICODE)
test_str = ("Ø£ØÙ…د\n"
"اØÙ…د\n"
"Ø¥ØÙ…د\n"
"Ø¢ØÙ…د")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")