# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s((http(s)?\:\\/\\/[a-zA-Z0-9\-\.]+\.)(com|org|net|mil|edu|))/<a href="$2">$2<a\/>/gmi;t' <<< "click on http://www.google.com
click onhttp://www.google.com"