use strict;
my $str = 'click on http://www.google.com
click onhttp://www.google.com';
my $regex = qr/\s((http(s)?\:\/\/[a-zA-Z0-9\-\.]+\.)(com|org|net|mil|edu|))/mip;
my $subst = '<a href="$2">$2<a/>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";