package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\s((http(s)?\:\/\/[a-zA-Z0-9\-\.]+\.)(com|org|net|mil|edu|))`)
var str = `click on http://www.google.com
click onhttp://www.google.com`
var substitution = "<a href="$2">$2<a/>"
fmt.Println(re.ReplaceAllString(str, substitution))
}