const regex = /\s((http(s)?\:\/\/[a-zA-Z0-9\-\.]+\.)(com|org|net|mil|edu|))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s((http(s)?\\:\\\/\\\/[a-zA-Z0-9\\-\\.]+\\.)(com|org|net|mil|edu|))', 'gmi')
const str = `click on http://www.google.com
click onhttp://www.google.com`;
const subst = `<a href="$2">$2<a/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);