re = /\s((http(s)?\:\/\/[a-zA-Z0-9\-\.]+\.)(com|org|net|mil|edu|))/mi
str = 'click on http://www.google.com
click onhttp://www.google.com'
subst = '<a href="$2">$2<a/>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result