import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s((http(s)?\\:\\/\\/[a-zA-Z0-9\\-\\.]+\\.)(com|org|net|mil|edu|))";
final String string = "click on http://www.google.com\n"
+ "click onhttp://www.google.com";
final String subst = "<a href=\"$2\">$2<a/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}