$re = '/\s((http(s)?\:\/\/[a-zA-Z0-9\-\.]+\.)(com|org|net|mil|edu|))/mi';
$str = 'click on http://www.google.com
click onhttp://www.google.com';
$subst = "<a href=\"$2\">$2<a/>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;