# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@(.*)(@[\s\S]*)@default\.\1.*/@$1$2/;t' <<< "@d.e.f@=y
@a.b.c@=x
@h.i.j@=aaaa
@default.a.b.c@=QQQ
@asdfasd.fasdfs.asdfa@=23423
@default.h.i.j@=234
@default.RR.TT@=393993
@x.y.z@=0
@default.q.r.s@=1
@l.m.n@=8.3
@q.r.s@=78
@blah.blah.blah@=blah"