const regex = /@(.*)(@[\s\S]*)@default\.\1.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@(.*)(@[\\s\\S]*)@default\\.\\1.*', '')
const str = `@d.e.f@=y
@a.b.c@=x
@h.i.j@=aaaa
@default.a.b.c@=QQQ
@asdfasd.fasdfs.asdfa@=23423
@default.h.i.j@=234
@default.RR.TT@=393993
@x.y.z@=0
@default.q.r.s@=1
@l.m.n@=8.3
@q.r.s@=78
@blah.blah.blah@=blah`;
const subst = `@$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);