import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@(.*)(@[\\s\\S]*)@default\\.\\1.*";
final String string = "@d.e.f@=y\n"
+ "@a.b.c@=x\n"
+ "@h.i.j@=aaaa\n"
+ "@default.a.b.c@=QQQ\n"
+ "@asdfasd.fasdfs.asdfa@=23423\n"
+ "@default.h.i.j@=234\n"
+ "@default.RR.TT@=393993\n"
+ "@x.y.z@=0\n"
+ "@default.q.r.s@=1\n"
+ "@l.m.n@=8.3\n"
+ "@q.r.s@=78\n"
+ "@blah.blah.blah@=blah";
final String subst = "@$1$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}